设为首页收藏本站 官方微信

创幻股票

 找回密码
 注册

扫一扫,访问微社区

查看: 31258|回复: 9

[通达信] 求“涨幅”公式(不要以为很简单,不信进来见详情))

[复制链接]
发表于 2009-7-17 23:36 | |阅读模式
我知道,涨幅的计算是:(C-REF(C,1))/REF(C,1)*100
这是今天相对于昨天的涨幅。
下面我想求两种涨幅的计算。

一:计算任意两天的涨幅。
例如,计算20080101至20081231某股的涨幅。

二:计算任意两天的累积涨幅。
这个跟前面那一个有点区别,我个人的理解是开头的那天(例如20080101)至结尾的那天(例如20081231),每一个交易日的涨幅的全部加到一起的值。

呵呵,我们仅仅讨论学习公式,不要有人跳出来说,20080101那天是假日,根本没开市之类的话……

期待你的解答。非常感谢!

重新编辑一下:求知道答案的朋友,原原本本回答我的两个问题吧,其它的就别扯了。
我最最感谢回答了我的问题了的朋友,其次感谢没有回答的朋友,感谢度最低的,就是回答了,但却不是我所问的问题的答案的朋友(这样说或者不妥,或者只是我很想表达一下,对那些答非所问的从心底油然而生起的无奈)

[ 本帖最后由 偶然间 于 2009-7-18 19:56 编辑 ]
 楼主| 发表于 2009-7-18 09:39 |
今年过年不收礼呀,要收只收炒股公式呀
我顶:期待你的解答。非常感谢!
发表于 2009-7-18 09:40 |

学习来了!

你有一个苹果,我有一个苹果。交换后还是一个苹果。
你有一种方法,我有一种方法。交流后就是两种方法。
发表于 2009-7-18 11:21 |
软件本身带这功能,按住右键拉出一个框,选阶段统计就行,仔细看看帮助文件吧。
发表于 2009-7-18 12:15 |
一品看帖:
楼主思路,其实就是一个阶段统计;飞狐等软件本身就有自带的统计功能;但,不少软件无法实现。
阶段涨跌幅,无论是对于选择龙头追涨,还是选择暴跌低吸,都是一个很好的参考!
为了弥补其他软件的不足,一品前期曾经编写过一个类似的【阶段统计】副图指标,提供给楼主与需要的朋友参考。
(提醒:非大智慧L2版本的软件,可以将最后【以下设置大智慧L2版本副图提示信息】那部分删除!这样就可以直接使用。)
{阶段统计----创幻论坛一品茶缘编写,大智慧L2版本副图指标}
{N1:1900,2500,2007;Y1:1,12,1;R1:1,31,8;----本行参数表示统计开始的年月日;}
{N2:1900,2500,2007;Y2:1,12,3;R2:1,31,30;----本行参数表示统计结束的年月日;}
{DDF:10,30,18;----表示阶段高点回落的跌幅;一般股票牛市可以只选择10,18为超跌安全买点;}
{阶段统计指标使用说明:
参数调整变周期,阶段统计比高低;
同期对比选龙头,黄坑提示可低吸。}
INPUT:N1(2007,1900,2500),Y1(1,1,12),R1(8,1,31),N2(2007,1900,2500),Y2(3,1,12),R2(30,1,31),DDF(18,1,31);
年:=YEAR;
月:=MONTH;
日:=DAY;
始:=年=N1 AND 月=Y1 AND 日=R1;
终:=年=N2 AND 月=Y2 AND 日=R2;
周期:BARSLAST(始),COLORFFFFFF;
涨幅:(C/REF(C,周期)-1)*100,COLOR00FFFF;
最高:(HHV(H,周期)/REF(C,周期)-1)*100*(周期>=1),COLORFF00FF;
活跃度:涨幅/周期,COLOR00FF00;
HLSJ:=BARSLAST(CROSS(最高=REF(最高,1),0.5))+1;
HJK:=(REF(H,HLSJ)/L-1)*100-DDF;
黄金坑:(HJK>0)*HJK,COLOR00FFFF;
{以下设置副图显示方式}
STICKLINE(始,0,50,1,0),COLOR00FF00;
STICKLINE(终,0,50,1,0),COLORFF00FF;
DRAWTEXT(始,80,'开始'),COLOR00FF00;
DRAWTEXT(终,80,'结束'),COLORFF00FF;
STICKLINE(黄金坑,涨幅,最高-DDF,4,0),COLOR00FFFF;
{以下设置大智慧L2版本副图提示信息}
DRAWTEXTREL(10,10,''+STKLABEL+' '+STKNAME),COLOR00FF00,LINETHICK2;
DRAWTEXTREL(10,150,'■起始时间:'+NUMTOSTRN(N1,0)+'年'+NUMTOSTRN(Y1,0)+'月'+NUMTOSTRN(R1,0)+'日'),COLOR00FFFF;
DRAWTEXTREL(10,250,'■结束时间:'+NUMTOSTRN(年,0)+'年'+NUMTOSTRN(月,0)+'月'+NUMTOSTRN(日,0)+'日'),COLOR00FFFF;
DRAWTEXTREL(10,350,'■统计周期:'+NUMTOSTRN(周期,0)+'天'),COLORFFFFFF;
DRAWTEXTREL(10,450,'■最高涨幅:'+NUMTOSTRN(最高,2)+'%'),COLOR0000FF;
DRAWTEXTREL(10,550,'■最后涨幅:'+NUMTOSTRN(涨幅,2)+'%'),COLORFF00FF;
DRAWTEXTREL(10,650,'■活跃程度:'+NUMTOSTRN(活跃度,2)+'%'),COLOR00FF00;
{阶段统计----创幻论坛一品茶缘编写,飞狐版本副图指标}
{N1:1900,2500,2007;Y1:1,12,1;R1:1,31,8;----本行参数表示统计开始的年月日;}
{N2:1900,2500,2007;Y2:1,12,3;R2:1,31,30;----本行参数表示统计结束的年月日;}
{DDF:10,30,18;----表示阶段高点回落的跌幅;一般股票牛市可以只选择10,18为超跌安全买点;}
{阶段统计指标使用说明:
参数调整变周期,阶段统计比高低;
同期对比选龙头,黄坑提示可低吸。}
INPUT:N1(2007,1900,2500),Y1(1,1,12),R1(8,1,31),N2(2007,1900,2500),Y2(3,1,12),R2(30,1,31),DDF(18,1,31);
年:=YEAR;
月:=MONTH;
日:=DAY;
始:=年=N1 AND 月=Y1 AND 日=R1;
终:=年=N2 AND 月=Y2 AND 日=R2;
周期:BARSLAST(始),COLORFFFFFF;
涨幅:(C/REF(C,周期)-1)*100,COLOR00FFFF;
最高:(HHV(H,周期)/REF(C,周期)-1)*100*(周期>=1),COLORFF00FF;
活跃度:涨幅/周期,COLOR00FF00;
HLSJ:=BARSLAST(CROSS(最高=REF(最高,1),0.5))+1;
HJK:=(REF(H,HLSJ)/L-1)*100-DDF;
黄金坑:(HJK>0)*HJK,COLOR00FFFF;
{以下设置副图显示方式}
STICKLINE(始,0,50,1,0),COLOR00FF00;
STICKLINE(终,0,50,1,0),COLORFF00FF;
DRAWTEXT(始,80,'开始'),COLOR00FF00;
DRAWTEXT(终,80,'结束'),COLORFF00FF;
STICKLINE(黄金坑,涨幅,最高-DDF,4,0),COLOR00FFFF;
{以下设置飞狐版本副图提示信息}
DRAWTEXTEX(1,10,1,0,STKLABEL+' '+STKNAME),COLOR00FF00,LINETHICK2;
DRAWTEXTEX(1,10,150,0,'■起始时间:'+NUMTOSTR(N1,0)+'年'+NUMTOSTR(Y1,0)+'月'+NUMTOSTR(R1,0)+'日'),COLOR00FFFF;
DRAWTEXTEX(1,10,150,150,'■结束时间:'+NUMTOSTR(年,0)+'年'+NUMTOSTR(月,0)+'月'+NUMTOSTR(日,0)+'日'),COLOR00FFFF;
DRAWTEXTEX(1,10,150,300,'■统计周期:'+NUMTOSTR(周期,0)+'天'),COLORFFFFFF;
DRAWTEXTEX(1,10,150,450,'■最高涨幅:'+NUMTOSTR(最高,2)+'%'),COLOR0000FF;
DRAWTEXTEX(1,10,150,600,'■最后涨幅:'+NUMTOSTR(涨幅,2)+'%'),COLORFF00FF;
DRAWTEXTEX(1,10,150,750,'■活跃程度:'+NUMTOSTR(活跃度,2)+'%'),COLOR00FFFF;

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
发表于 2009-7-18 13:09 |
TDX主图
 楼主| 发表于 2009-7-18 19:46 |
各位兄弟姐妹,高手长老
就没有人原原本本的回答我的问题吗?
发表于 2009-7-22 08:51 |
顶,
发表于 2009-11-18 20:44 |
dddddddd
发表于 2009-11-18 21:28 |
原帖由 偶然间 于 2009-7-17 23:36 发表
我知道,涨幅的计算是:(C-REF(C,1))/REF(C,1)*100
这是今天相对于昨天的涨幅。
下面我想求两种涨幅的计算。

一:计算任意两天的涨幅。
例如,计算20080101至20081231某股的涨幅。

二:计算任意两天的累积涨 ...



本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x


快速回复 返回顶部 返回列表